Linux安装Python编辑器IDLE的问题如何解决?

最近由于科研需要初学Linux,有个问题想请教各位。
实验室建了个服务器,以最小安装模式装了Linux,结果装上Python后没法用IDLE编辑器。我把gcc、Tcl、Tk、Tkinter都装了一遍,又重装一遍Python2.7.3。这时在usr/local/bin里已经可以看到idle文件了,但是在命令行中直接键入idle,结果如下:
[***@localhost Python-2.7.3]$ idle
Traceback (most recent call last):
File "/usr/local/bin/idle", line 5, in <module>
main()
File "/usr/local/lib/python2.7/idlelib/PyShell.py", line 1406, in main
root = Tk(className="Idle")
File "/usr/local/lib/python2.7/lib-tk/Tkinter.py", line 1685, in __init__
self.tk = _tkinter.create(screenName, baseName, className, interactive, wantobjects, useTk, sync, use)
_tkinter.TclError: no display name and no $DISPLAY environment variable

请问这是为什么?该如何解决?谢谢大家啦!
PS:我所有操作都是在Win7的SecureCRT终端下完成的

推荐  (0) | 2人关注关注
3个答案
2 0

艾斯昆程序员,科幻迷

2012-04-21 22:49
支持者: nipper HX

IDLE是基于X的,直接ssh上去当然不能用,而且你的Linux上X也没装。写python的话vim什么的,REPL推荐ipython/bpython。

1 0
支持者: 俊杰啊ahaha

sudo apt-get install idle
ok 一步搞定

0 0

SecureCRT的情况不太清楚,我用putty做ssh,在建立session的时候使能X11 forwarding,再在Windows上安装一个xming,就搞定了。可以参考下面步骤:
1. 在windows上安装Xming(一个X display 工具),启动Xming
2. 在windows上安装Putty,
3. 在putty上建立ssh session的时候做如下配置:
点选Category -> Connection -> SSH -> X11 ,在SSH X11 forwarding 配置中勾选 “Enable X11 forwarding”
4. 保存配置,打开ssh连接,
5. 在linux shell 下键入命令idle,就会有idle的窗口弹出

查看更多

添加回答

登录 后回答问题,你也可以用以下帐号直接登录

相关问答

关于我们 加入果壳 媒体报道 帮助中心 果壳活动 家长监控 免责声明 联系我们 移动版 移动应用

©果壳网    京ICP证100430号    京网文[2018] 6282-492号    新出发京零字东150005号     京公网安备11010502007133号

违法和不良信息举报邮箱:jubao@guokr.com    举报电话:18612934101    网上有害信息举报专区    儿童色情信息举报专区